What is the correct video software?



You need the latest Adobe Acrobat Reader (Version 8 minimum, ideally version 9 or 10 [X]) and Adobe Flash Video player (Version 10.2.152 minimum)
So, the easiest way to know if you have the right versions is just to follow the links below and download them, if they are already installed then the installation process will tell you. This really is the easiest way to avoid problems at any time.
Adobe Acrobat Reader: Click here
Adobe Flash Video Player: Click here

This entry was posted in News. Bookmark the permalink.

Comments are closed.